Important Information about the upcoming LocatorHub 5.4 Release

Esri UK is busy working on the 5.4 release for LocatorHub which will support the new schema for AddressBase Premium, which is being introduced by Ordnance Survey at Epoch 39 (10th March 2016).  We plan to release 5.4 on the 4th March 2016.

Please be aware that you will need to upgrade to LocatorHub 5.4 to continue loading AddressBase Premium from Epoch 39, but LocatorHub 5.4 will not support the current schema (up to Epoch 38). You will need to plan your upgrade carefully, please see this document for advice on upgrading to LocatorHub 5.4

The scope of the 5.4 release is:

  • Support for new AddressBase Premium Schema
  • Support for Windows 10
  • Certification for ArcGIS for Server 10.4
  • Bug fixes

As part of this release we are also changing the support status on a number of features within LocatorHub which are no longer in use or have been replaced by newer technology.  A summary of the changes is provided below.  We will be publishing this information in the Product Lifecycle from the 5.4 release. 

Changes to support status of locators:

  • Experian Goad Locator – Retired
  • National Street Gazetteer (NSG) DTF7.1 – moving to Mature Support as data will no longer be available in this format from May 2016. We currently have no plans to support DTF 8.1 format.
  • OS Address Point, OS MasterMap AddressLayer II, OS Locator – moving to Mature Support (these products are being withdrawn by the Ordnance Survey)

Changes to support status of functional areas:

  • SOAP Web Service (http://<server>/lh/locatorhub.asmx) will move to Mature Support (note: SOAP services are still available through the http://<server>/locatorhub/locatorhub.svc end point and can be used by all LocatorHub clients such as the LTS, Editor and the Services Add-in)
  • Scheduled tasks will move to Mature Support
  • Candidate processing will move to Mature support

Changes to the LocatorHub Editor:

  • The AddressBase Premium and BS7666 editable schemas have been removed from the core product and now require a separate install (if you are currently using these schemas please contact the Product Manager)

Changes to supported operating systems for the desktop clients:

  • Windows 8 will no longer be supported, but we continue to support Windows 7, Windows 8.1 and have added support for Windows 10.

If you have any questions please contact the Product Manager